环境:
Oracle Linux 6.8

安装Oracle 12.2.0.1版本时,第一步就跳出这个报错界面:

[INS-13001]Oracle Database is not supported on this operating system
Installer will not perform prerequisite checks on the system.

看字面意思还以为是系统版本不支持。
看看产生的日志错误:
$vim /tmp/OraInstall2017-12-19_07-54-08PM/oraInstall2017-12-19_07-54-08PM.err

---# Begin Stacktrace #---------------------------
ID: oracle.install.ivw.common.validator.SupportedOSValidator:308
oracle.cluster.verification.VerificationException: PRVG-11322 : One or more node names "eas_dev" contain one or more of the following invalid characters "_"

是说系统的主机名”eas_dev”有个无效字符”_”

把主机名去掉_,改成其它的就可以了。

查了一下,Oracle从12.1.0.2开始,不支持主机名带”下划线_”了,支持”连字符-“

官方文档:
https://support.oracle.com/knowledge/Oracle%20Database%20Products/1957895_1.html