一、前言
二、OpenSSL版本和OpenSSH版本依赖关系
三、不升级OpenSSL的情况下升级OpenSSH
四、升级OpenSSL的情况下升级OpenSSH

一、前言

在Linux系统上,由于安全考虑,有时候会需要升级OpenSSH的版本。
由于OpenSSH是依赖OpenSSL的,所以要想升级OpenSSH有时候并没那么容易。还需要考虑OpenSSL的版本。

但系统的OpenSSL并不能直接进行升级的,因为系统上非常多的软件都对它有依赖性的,一旦升级OpenSSL或者出现问题,可能引起非常多的软件没办法使用,系统也就基本上坏了。

所以要想升级OpenSSH,有两种情况:
一种是不升级OpenSSL的情况下进行升级,这种情况下比较简单。
一种是需要先升级OpenSSL的情况下进行升级,这种情况下就稍微比较复杂一点了。

二、OpenSSL版本和OpenSSH版本依赖关系

本文隐藏内容需付费查看, 点击文章最后链接付费查看